Back to overview
Degraded

Cloudflare outage impacting Hoseki services

Nov 18 at 01:04pm CET
Affected services
API
Proof of Reserves
Prove
Verify

Resolved
Nov 18 at 07:30pm CET

Cloudflare has restored normal operation across their network, and all Hoseki services have recovered.

Created
Nov 18 at 01:04pm CET

We are currently experiencing degraded performance across several Hoseki features due to a widespread Cloudflare outage affecting authentication and on-chain infrastructure.