Back to overview
Degraded

Root API path has become unavailable

Feb 19 at 10:21am CET
Affected services
Hoseki API

Resolved
Feb 19 at 09:27pm CET

A patch has been applied to restore the root endpoint temporarily, resolving the 404 errors.

Both the root and /api paths are now functioning, ensuring no further immediate disruptions.

The root path remains deprecated. All users are strongly encouraged to update integrations to api.hoseki.app/api.

Documentation has been updated, and usage will be monitored. Further notice will be provided before the root endpoint is permanently removed.

Created
Feb 19 at 10:21am CET

During the transition to the new /api endpoint, the root path (api.hoseki.app/) became instantly unavailable instead of being gradually phased out.

The root endpoint was deprecated without a proper grace period, resulting in unexpected 404 errors for users who had not migrated.

Users relying on the root path experienced service interruptions.

A fix is in progress to restore temporary access to the root path while encouraging migration to api.hoseki.app/api.